2016HDU多校联赛-HDU-5813-Elegant Construction(构造联通图)

Elegant Construction

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 301 Accepted Submission(s): 158
Special Judge

Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it’s your showtime!

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.

Output
For each test case, output “Case #X: Y” in a line (without quotes), where X is the case number starting from 1, and Y is “Yes” if you can construct successfully or “No” if it’s impossible to reach the requirements.

If Y is “Yes”, output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.

Sample Input
3
3
2 1 0
2
1 1
4
3 1 1 0

Sample Output
Case #1: Yes
2
1 2
2 3
Case #2: No
Case #3: Yes
4
1 2
1 3
2 4
3 4

题意:第一行给出T,代表有T组数据,每组数据首先给出N,代表有1~N个点,接着一行给出N个数,第i个数代表第i个点能到达Ai个点,直接间接都行。

当时不会做,后来看题解又补的。

官方题解:将顶点按能到达的点数从小到大排序,排好序之后每个点只能往前面的点连边. 因而如果存在一个排在第i位的点,要求到达的点数大于i-1,则不可行;否则就可以按照上述方法构造出图. 复杂度O(N^2).

代码

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=1005;
struct node
{
    int num;
    int point;
} num[maxn];
bool cmp(node x,node y)
{
    return x.num<y.num;
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int casen=1; casen<=T; casen++)
    {
        int N;
        scanf("%d",&N);
        bool flag=0;//满足条件标记为1,否则为0
        for(int i=0; i<N; i++)
        {
            scanf("%d",&num[i].num);
            num[i].point=i+1;
            if(num[i].num==0)
                flag=1;
        }
        sort(num,num+N,cmp);
        int sum=0;//边的数量
        for(int i=0; i<N; i++)
        {
            if(num[i].num>=i+1)//存在一个排在第i位的点,要求到达的点数大于i-1,则不可行
            {
//                printf("***\n");
//                printf("%d %d\n",num[i].num,num[i].point);
                flag=0;
                break;
            }
            sum+=num[i].num;
        }
        if(flag==0)
        {
            printf("Case #%d: No\n",casen);
            continue;
        }
        printf("Case #%d: Yes\n%d\n",casen,sum);
        for(int i=0; i<N; i++)
            for(int j=0; j<num[i].num; j++)
                printf("%d %d\n",num[i].point,num[j].point);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值