hdu 5014__Number Sequence

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2044    Accepted Submission(s): 798
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4
 

Source
 
题意:给出一个数字n,接下来输入n+1个数字记为数列a,这些数字不重复且大于等于从0到n。现要求另一数列b(特性与a数列一致)使得对应(a0+b0)^(a1+b1)^(a2+b2)^...^(an+bn)所得值最大。

想法:对于一个数a,从0到a的数字中与它异或得最大值的只有它的取反的数。例如5->101;从0到5里应该取010,这样就能够利用贪心思想,从大到小,求出与之对应的那个值。

代码如下:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
    int n,b[100000+10],a,ans[100000+10];
    while(~scanf("%d",&n)) {
        memset(ans,0,sizeof(ans));
        long long sum=0;
        for(int i=n;i>=0;--i) {
            if(ans[i]==0) {
                int t=i,k=0;
                while(t) {
                    b[k]=t%2;
                    k++;
                    t/=2;
                }
                for(int j=0;j<k;++j) {
                    b[j]=!b[j];
                    ans[i]+=b[j]*pow(2,j);
                }
                ans[ans[i]]=i;
                sum+=ans[i]^i;
            }
        }
        printf("%I64d\n",sum*2);
        for(int i=0;i<=n;i++) {
            scanf("%d",&a);
            if(i==0) {
                printf("%d",ans[a]);
            }
            else
                printf(" %d",ans[a]);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值