NYOJ 927 The partial sum problem

The partial sum problem

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
One day,Tom’s girlfriend give him an array A which contains N integers and asked him:Can you choose some integers from the N integers and the sum of them is equal to K. 
输入
There are multiple test cases.
Each test case contains three lines.The first line is an integer N(1≤N≤20),represents the array contains N integers. The second line contains N integers,the ith integer represents A[i](-10^8≤A[i]≤10^8).The third line contains an integer K(-10^8≤K≤10^8).
输出
If Tom can choose some integers from the array and their them is K,printf ”Of course,I can!”; other printf ”Sorry,I can’t!”.
样例输入
4
1 2 4 7
13
4
1 2 4 7
15
样例输出
Of course,I can!

Sorry,I can't!

思路:首先看到这道题的第一反应就是用for循环,但是因为不知道有多少个数字所以就没法确定有多少个for循环而且n较多的话根本不能用for循环,所以这时候我们就想到了深搜,一个一个的进行搜索。

代码:

 
#include<stdio.h>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
#include<stack>
#include<vector>
#include<string.h>
#include<map>
#define INF 0x3f3f3f3f3f
using namespace std;
int flag,sum,k,n,a[101];
void dfs(int t)
{
    if(sum>k)
    {
        return;//如果大于k就跳出
    }
    if(sum==k)
    {
        flag=1;//等于k的话做一下标记
    }
    for(int i=t;i<n;i++)//深搜找出相加等于k的最佳路径
    {
        sum+=a[i];
        dfs(i+1);
        sum-=a[i];//如果不想等的话还要将其回复称相加之前的状态,集训进行下一个循环寻找
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        flag=0;sum=0;
        for(int i=0;i<n;i++)
        {
        scanf("%d",&a[i]);
        }
        scanf("%d",&k);
        dfs(0);
        if(flag==1)//flag==1证明找到按要求输出即可
        {
            printf("Of course,I can!\n");
        }
        else
        {
            printf("Sorry,I can't!\n");
        }
    }
}        


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值