927 The partial sum problem【dfs】

36 篇文章 0 订阅

The partial sum problem

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
One day,Tom’s girlfriend give him an array A which contains N integers and asked him:Can you choose some integers from the N integers and the sum of them is equal to K. 
输入
There are multiple test cases.
Each test case contains three lines.The first line is an integer N(1≤N≤20),represents the array contains N integers. The second line contains N integers,the ith integer represents A[i](-10^8≤A[i]≤10^8).The third line contains an integer K(-10^8≤K≤10^8).
输出
If Tom can choose some integers from the array and their them is K,printf ”Of course,I can!”; other printf ”Sorry,I can’t!”.
样例输入
4
1 2 4 7
13
4
1 2 4 7
15
样例输出
Of course,I can!
Sorry,I can't!

给出一些数,让你输出是否可以累加某些值得到指定的结果,dfs题目,比较简单的方法就是每个物品有选和不选两种情况,依次递归下去,出现需要的结果就标记上,然后输出对应结果,注意条件的控制,一切ok..




#include<stdio.h>
int n,m,x[105],kase;
void dfs(int i,int s)
{
	if(i>n||s>m||kase)
	{
		return;
	}
	if(s==m)
	{
		kase=1;
		return;
	}
	dfs(i+1,s);//不选
	dfs(i+1,s+x[i]);//选
} 
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;++i)
		{
			scanf("%d",x+i);
		}
		scanf("%d",&m);
		kase=0;
		dfs(0,0);
		if(kase)//标记变量
		{
			printf("Of course,I can!\n");
			continue;
		}
		printf("Sorry,I can't!\n");
	} 
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值