NYOJ 927 The partial sum problem (DFS)


The partial sum problem

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
One day,Tom’s girlfriend give him an array A which contains N integers and asked him:Can you choose some integers from the N integers and the sum of them is equal to K. 
输入
There are multiple test cases.
Each test case contains three lines.The first line is an integer N(1≤N≤20),represents the array contains N integers. The second line contains N integers,the ith integer represents A[i](-10^8≤A[i]≤10^8).The third line contains an integer K(-10^8≤K≤10^8).
输出
If Tom can choose some integers from the array and their them is K,printf ”Of course,I can!”; other printf ”Sorry,I can’t!”.
样例输入
4
1 2 4 7
13
4
1 2 4 7
15
样例输出
Of course,I can!
Sorry,I can't!

部分和问题,使用DFS求解 ,与NYOJ 1058一样

一:

 参见《挑战程序设计竞赛》
#include <iostream>
#include <cstring>
using namespace std;

int n, k;
int a[25], b[25];

//已经从前i项得到了和sum,然后对于i项之后的进行分支
bool dfs(int i, int sum)
{
    //如果前i项都计算过了,则返回sum是否与k相等
    if (i == n)
        return sum == k;
   // b[i] = 0;
    //不加上a[i]的情况
    if (dfs(i + 1, sum))
        return true;
    //b[i] = 1;
    //加上a[i]的情况
    if (dfs(i + 1, sum + a[i]))
        return true;
    //无论是否加上a[i]都不能凑成k就返回false
    return false;
}

int main()
{
    while (cin >> n){
        for (int i = 0; i < n; i++)
            cin >> a[i];
        cin >> k;
        if (dfs(0, 0)){
            cout << "Of course,I can!" << endl;
            //for (int i = 0; i < n; i++){
                //if (b[i])
                  //  cout << a[i] << " ";
            }
            //cout << endl;
        }
        else
            cout << "Sorry,I can't!" << endl;
    }
    return 0;
}
        

二:

 
#include <iostream>
using namespace std;
typedef long long ll;
int n, k;
ll a[25];
ll sum;
int flag;
void dfs(int x)
{
    if (sum > k)
        return;
    if (sum == k)
        flag = 1;
    for (int i = x; i < n; i++){
        sum += a[i];
        dfs(i + 1);
        sum -= a[i];
    }
}

int main()
{
    while (cin >> n){
        sum = 0, flag = 0;
        for (int i = 0; i < n; i++)
            cin >> a[i];
        cin >> k;
        dfs(0);
        if (flag)
            cout << "Of course,I can!" << endl;
        else
            cout << "Sorry,I can't!" << endl;
    }
}
        


深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值