Orderly Class

时间限制: 1 Sec  内存限制: 128 MB
 

题目描述

Ms. Thomas is managing her class of n students.
She placed all her students in a line, and gave the i-th student from the left a card with the letter ai written on it.
She would now like to rearrange the students so that the i-th student from the left has a card with the letter bi written on it.
To do this, she will choose some consecutive group of students, and reverse their order. Students will hold on to their original cards during this process.
She’s now wondering, what is the number of valid ways to do this? (It may be impossible, in which case, the answer is zero).
With sequences abba and aabb, Ms. Thomas can choose the group a(bba). With sequences caxcab and cacxab, Ms. Thomas can choose ca(xc)ab or c(axca)b. With sequences a and z, there are clearly no solutions.

输入

The input is two lines of lowercase letters, A and B. The i-th character of A and B represent ai and bi respectively. It is guaranteed that A and B have the same positive length, and A and B are not identical. The common length is allowed to be as large as 100 000.

输出

For each test case, output a single integer, the number of ways Ms. Thomas can reverse some consecutive group of A to form the line specified by string B.

样例输入

abba
aabb

样例输出

1

 

奇怪的题目,不知道是不是我理解有问题

 

Ac代码

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <map>
#define pi acos(-1.0)
#define inf 0x3f3f3f3f
#define linf 0x3f3f3f3f3f3f3f3fLL
#define ms(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;

char a[100005];
char b[100005];
int main()
{
    scanf("%s%s",a,b);
    ll ti,tj;
    ll len=strlen(a);
    ti=0,tj=len-1;


    while(a[ti]==b[ti])ti++;
    while(a[tj]==b[tj])tj--;

    ll ans=0;

    while(ti>=0 && tj<len)
    {
        if(a[ti]==b[tj]&&a[tj]==b[ti]){
            ans++;
            ti--,tj++;
        }
        else
            break;

    }
    printf("%lld\n",ans);

    return 0;
}

 

 

 

Wa代码

 

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <map>
#define pi acos(-1.0)
#define inf 0x3f3f3f3f
#define linf 0x3f3f3f3f3f3f3f3fLL
#define ms(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
 
char a[100005];
char b[100005];
int vis1[27];
int vis2[27];
 
int jude(ll l,ll r)
{
    for(ll i=0;i<=(r-l+1)/2;i++)
    {
        if(a[l+i]!=b[r-i])
        {
            return 0;
        }
    }
    return 1;
}
 
int main()
{
    scanf("%s%s",a,b);
    ll ti,tj;
    ll len=strlen(a);
    ti=0,tj=len-1;
 
    for(ll i=0;i<len;i++)
    {
        if(!vis1[a[i]-'a'])
            vis1[a[i]-'a']=1;
        if(!vis2[b[i]-'a'])
            vis2[b[i]-'a']=1;
    }
 
    for(int i=0;i<27;i++)
    if(vis1[i]!=vis2[i])
    {
        printf("0\n");
        return 0;
    }
 
 
    while(a[ti]==b[ti])ti++;
    while(a[tj]==b[tj])tj--;
 
    ll ans=0;
 
    while(ti>=0 && tj<len)
    {
        if(jude(ti,tj))
        {
            ans++;
        }
        ti--,tj++;
    }
    printf("%lld\n",ans);
 
    return 0;
}

意思变了,ac的是中间的不管,wa的是指中间也要镜像

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值