POJ 3617 Best Cow Line(贪心)

Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10967 Accepted: 3269

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source


题意:

有一个长度为N字符串S,构造一个长度为N的新字符串T。可以选择从S的头尾选择字符放入新字符串,但必须保证T的字典序尽量小。

思路:

设置两个角标变量从头尾开始不断比较放入,遇到前后相同的继续比较,直到比较出较小的一端。输出的时候比较坑,80个一组,换行,最后一组不用换,需要注意。

代码如下:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <cstring>
using namespace std;
#define MAX_N 2005
char S[MAX_N];
char T[MAX_N];
int main()
{
    int n,length,x,y;
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>S[i];
    length=0;
    x=0;y=n-1;//首尾开始遍历
    while(length<n)
    {
        if(S[x]<S[y])
        {
            T[length]=S[x];
            x++;
        }
        else if(S[x]>S[y])
        {
            T[length]=S[y];
            y--;
        }
        else//相同的情况
        {
            for(int i=0;x+i<=y;i++)//比较从哪端开始较小
            {
                if(S[x+i]<S[y-i])
                {
                    T[length]=S[x];
                    x++;
                    break;
                }
                else if(S[x+i]>S[y-i])
                {
                    T[length]=S[y];
                    y--;
                    break;
                }
            }
            if(T[length]=='\000')//回文串的情况,从任意端开始都可以
            {
                T[length]=S[x];
                x++;
            }
        }
        length++;
    }
    for(int i=1;i<=n;i++)//输出需要注意
    {
        cout<<T[i-1];
        if(i%80==0&&i!=n)
            cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值