Cleaning Shifts POJ - 2376

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input
* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
Output
* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
Sample Input
3 10
1 7
3 6
6 10
Sample Output
2
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

传送门:点击打开链接

思路:这个题是个比较简单的贪心题目,选出需要的最少的奶牛数量,这个题只需要保证每次选择的奶牛都是当前要选择的最优的一个。(一开始错了几次是因为没有考虑到奶牛的结束时间可能会大于T)

#include <iostream>
#include <algorithm>
#include <string>
#include <ctime>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <cstring>
#define MAXN 25100
using namespace std;

struct Node{
    int start_time;
    int end_time;
};

bool cmp(const Node &x1, const Node &x2){
    if(x1.start_time == x2.start_time)
        return x2.end_time > x2.end_time;
    return x1.start_time < x2.start_time;
}

int main(){
    int n, T;
    Node cow[MAXN];
    while(cin >> n >> T){
        for(int i = 0; i < n; ++i)
            cin >> cow[i].start_time >> cow[i].end_time;
        sort(cow, cow + n, cmp);
        int time = 0;
        int ans = 0;
        int last_time = 0;
        bool flag = false;
        for(int i = 0; i < n; ++i){
            bool xx = false;
            while(cow[i].start_time <= last_time + 1){
                xx = true;
                time = max(time, cow[i].end_time);
                i++;
            }
            last_time = time;
            ans++;
            if(xx)
                i--;
            if(last_time >= T){
                flag = true;
                break;
            }
        }
        if(flag)
            cout << ans << endl;
        else
            cout << -1 << endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值