HDU_2955 Robberies(DP,01,double)

Robberies

Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output
2
4
6

题解:
题意告诉我们最大允许的失败率,以及单独每家银行的失败率。英文题大家很容易理解错题意,而且碰巧这道题的样例很坑爹。但是我们在列出dp递推式之前一定要明白下面几点:

1.每个事件是独立的,但是成功率V=V1*V2*….*Vn;而我们要保证的是(1-V)< F, F即所给失败率。
2.按一般思路因为背包容量对应的是失败率,dp数组应该对应去设,但是失败率对应的是double型的小数,并且我们不能仅仅依靠*100去求解(题目没有说明保留两位,失败率可能会精确到小数点后更多),所以这样设不行。

但是注意到我们能估算出最大金额(100*100),所以我们可以转换思路定义得到i万元的成功几率,倒序更新i的可达性,也是一种很好的方法。

算法:
定义dp[i]:得到i万元的成功几率;
递推关系:dp[j]=max(dp[j],dp[j-c[i]]*(1-w[i]));
O(NV)
优化:V=sum_c,sum_c为所有钱数总和,j不可能超过sum_c,内层遍历sum_c~c[i];

附代码:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <limits.h>
#include <cstring>
#define MAX_N 110
#define MAX_M 10010
using namespace std;

double dp[MAX_M];
double sum;
int T,num,result,sum_c;
int c[MAX_N];
double w[MAX_N];
int main()
{
    cin>>T;
    while( T-- )
    {
        scanf("%lf%d",&sum,&num);
        sum_c=0;
        for( int i = 0; i < num; i++ )
        {
            scanf("%d%lf",&c[i],&w[i]);
            sum_c+=c[i];
        }
        memset(dp,0,sizeof(dp));
        //初始化什么也不偷的成功率为1
        dp[0]=1;result=0;
        for( int i = 0; i < num; i++ )
        {
            for( int j = sum_c; j >= c[i]; j-- )
                dp[j]=max(dp[j],dp[j-c[i]]*(1-w[i]));
        }
        result=sum_c;
        while( dp[result] < 1-sum )
            result--;
        printf("%d\n",result);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值