Saruman‘s Army(贪心)

Saruman’s Army(贪心)

Description
Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.
Input
The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.
Output
For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output
2
4

题意:给定几个坐标点和眼石的半径,求最少用几个眼石可以覆盖全部军队,也就是用几个半径为r的圈可以覆盖全部的点。

题解:先对点由小到大排序,从左边最小的点开始,用该值加上R的值,找到从该点开始能覆盖到的最大范围,标记这个范围内最右边的数值 ,然后再用这个标记的数值加上半径R,找到此时的最大覆盖范围,这样就完成了第一轮标记。第二轮再从最左边未被覆盖到的第一个点开始,反复进行该过程
,直到把所有的点都覆盖,标记的数量即为最小值。

AC代码:

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <math.h>

using namespace std;

int main()
{
    int R,n,a[1005];          
    while(~scanf("%d%d",&R,&n))
    {
        if(R==-1&&n==-1)
            break;
        for(int i=0; i<n; i++)
            cin>>a[i];
        sort(a,a+n);           //从小到大排序;
        int left,right,ans=0,i=0;   //用ans来统计标记的数量;
        while(i<n)
        {
            left=a[i];       //左边未被覆盖到的值;
            i++;
            while(i<n&&a[i]<=left+R)      //寻找超出覆盖范围的第一个值;
                i++;
            right=a[i-1];                //i-1为覆盖范围最右边的值;
            while(i<n&&a[i]<=right+R)    //找到超出覆盖范围的第一个值;
                i++;
            ans++;                       //一轮查找结束,标记的数量加1;
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值