Moving Tables

Moving Tables

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
在这里插入图片描述

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
在这里插入图片描述

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30

题意:有N张桌子,把桌子从一个房间搬到另一个房间要经过走廊,如果搬运多张桌子的时候走廊没有被共享,那么多张桌子可以同时搬运,如果走廊被共享就无法同时进行搬运,求搬运完所有桌子所需的最短时间。

题解: 走廊共享也就是区间相交问题,如果走廊没有共享也就意味着区间没有相交的部分,那么所有的桌子可以一次性同时进行搬运,所花时间仅为10,当有两段区间是相交时,意味着这两个有一个需要等另外一个搬运完成后在进行搬运,其它可以同时进行搬运,所以我们会发现,搬运所花费的最小时间应该是相交的区间的个数,可以用被经过最多的房间的次数乘10来作为最少时间。需要注意的就是奇数和偶数不是在同一排的,我们可以把给定房间的区间最大化。

AC代码:

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <math.h>

using namespace std;

struct room             //用结构体来存搬运房间的起始号码;
{
    int s,t;
} x[2000];
int main()
{
    int T,n;
    cin>>T;
    while(T--)
    {
        cin>>n;
        for(int i=0; i<n; i++)
        {
            cin>>x[i].s>>x[i].t;
            if(x[i].s>x[i].t)
                swap(x[i].s,x[i].t);     //注意房间号不一定是后面比前面的大;
            if(x[i].s%2==0&&x[i].t%2!=0) //根据房间号的奇偶来“扩大”范围;
            {
                x[i].s=x[i].s-1;
                x[i].t=x[i].t+1;
            }
            else if(x[i].s%2!=0&&x[i].t%2!=0)
                x[i].t=x[i].t+1;
            else if(x[i].s%2==0&&x[i].t%2==0)
                x[i].s=x[i].s-1;
        }
        int flag[405];         //用来标记每个房间被走过的次数;
        memset(flag,0,sizeof(flag));   //先进行初始化;
        for(int i=0; i<n; i++)
        {
            for(int j=x[i].s; j<=x[i].t; j++)
            {
                flag[j]++;
            }
        }
        sort(flag,flag+405,greater<int>()); //从大到小排序,取最大值;  
        int mmax=flag[0];
        cout<<mmax*10<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值