Hat‘s Fibonacci(高精度+打表)

Hat’s Fibonacci(高精度+打表)

description:

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
Input
Each line will contain an integers. Process to end of file.
Output
For each case, output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

题解:
本题考查高精度运算,还是通过打表来进行数据存储,由于数字最大不超过2005位,二维数组又不能开太大,所以二维数组的每一位可以存>=4个数字。

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <iostream>
using namespace std;

int f[10000][555];                  
int main()
{
    f[1][0]=f[2][0]=f[3][0]=f[4][0]=1;         //把前四个先赋为1;   
    for(int i=5; i<10000; i++)                 //循环赋值;
    {
        for(int j=0; j<=505; j++)
        {
            f[i][j]=f[i-1][j]+f[i-2][j]+f[i-3][j]+f[i-4][j];  //二维数组每位装4个数;
        }
        int m=0;                             //m存进位;
        for(int j=0; j<555; j++)
        {
            int sum=f[i][j]+m;
            m=sum/10000;
            f[i][j]=sum%10000;         
        }
    }
    int n,flag=0;
    while(~scanf("%d",&n))
    {
        for(int i=554; i>=0; i--)
        {
            if(f[n][i]==0)
                continue;
            else
            {
                printf("%d",f[n][i]);    //把第一个数单独输出;
                flag=i;
                break;
            }
        }
        for(int i=flag-1; i>=0; i--)    //其他数每4位输出;
        {
            printf("%04d",f[n][i]);
        }
        cout<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值