Oil Deposits(DFS)

Oil Deposits
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits.
GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides
the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to
determine whether or not the plot contains oil.
A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the
same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to
determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number
of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input;
otherwise 1 ≤ m ≤ 100 and 1 ≤ n ≤ 100. Following this are m lines of n characters each (not counting
the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the
absence of oil, or ‘@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same
oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.

Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
*** * @
@@@
@ @
@@@
@
@@**@
0 0

Sample Output
0
1
2
2

题意:差不多意思就是找有多少个相邻的@组成的块,这里所谓的相邻是指一个矩形的区域,一共有八个方向。
题解:简单的深搜题,也可以用BFS来做,可以作为深搜的模板题。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

char a[105][105]; 
int dx[9]= {0,0,-1,-1,-1,1,1,1},dy[9]= {1,-1,0,-1,1,0,-1,1}; //偏移量;
int n,m,ans; 

void dfs(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m&&a[x][y]=='@')
        a[x][y]='*';     //满足条件的,为了避免重复,走过后就把@变成*;
    else return ;
    for(int i=0; i<8; i++)    //递归调用;
        dfs(x+dx[i],y+dy[i]);
}
int main()
{
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
            break;
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                cin>>a[i][j];
        ans=0;
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
            {
                if(a[i][j]=='@')      //遇到@时开始进行深搜;
                {
                    dfs(i,j);
                    ans++;    //每次搜索完成后一定要把ans加一;
                }
            }
        cout<<ans<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值