PAT:A1015 Reversible Primes (20 分)
A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes
if N is a reversible prime with radix D, or No
if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
代码:
#include<cstdio>
#include<algorithm>
bool isPrime(int n) {
if(n <= 1) return false;
for(int i = 2; i * i <= n; i++) {
if(n % i == 0) return false;
}
return true;
}
int d[111];
int main() {
int n, radix;
while(scanf("%d", &n) != EOF) {
if(n < 0) break;
scanf("%d", &radix);
bool isFlag, isFlag1;
isFlag = isPrime(n);
if(isFlag == false) printf("No\n");
else {
int i = 0, count = 0;
while(n != 0) {
d[i++] = n % radix;
n = n / radix;
}
for(int j = 0; j < i; j++) {
count = count*radix + d[j];
}
isFlag1 = isPrime(count);
if(isFlag1) printf("Yes\n");
else printf("No\n");
}
}
}