PAT甲级-1015 Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10
​5
​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

题目大意
每行给出两个数n和d,如果n是素数且n在d进制下反转后依然是素数就输出Yes,否则No

#include<bits/stdc++.h>
using namespace std;
vector<int>trans;//存储在d进制下反转后的数
void TransTo_d(int n,int d)//十进制转换为d进制
{
	while(n)
	{
		trans.push_back(n%d);
		n=n/d; 
	}
}
int TransTo_10(int d)//d进制转换为10进制
{
	int ans=0;
	int len = trans.size();
	for(int i=0;i<len;i++)
		if(trans[i])
			ans+=trans[i]*pow(d,(len-i-1));
	return ans;
}
bool isPrime(int n)
{
	if(n==0||n==1) return false;
	if(n==2) return true;
	for(int i=2;i*i<=n;i++)
		if(n%i==0)
			return false;
	return true;
}
int main()
{
	int n,d,rev;
	while(cin >> n)
	{
		if(n<0)break;
		cin >> d;
		trans.clear();
		TransTo_d(n,d);
		rev = TransTo_10(d);
		if(isPrime(rev)&&isPrime(n))
			cout << "Yes" << endl;
		else
			cout << "No" << endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值