「1015」Reversible Primes

ENTRY

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers and (1< ≤10), you are supposed to tell if is a reversible prime with radix .

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers and . The input is finished by a negative .

Output Specification:

For each test case, print in one line Yes if is a reversible prime with radix , or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

Ω

极简翻译:给出好几组数,一组一行。一组数包含一个十进制数 和一个进制数 ,如果 是一个素数且在 进制下的反转数也是素数,那么便输出Yes,反之输出No。最后以一个负数表示结束。

《日常水文章系列》

⚠️本题唯一需要注意的地方是判断素数一定要考虑1。

对于在 进制下求 的十进制反转数,由于 出来的依次是反转数的最高位到最低位,因此用一个循环即可:

int rn=0;
    while(n>0)
    {
      rn=rn*d+n%d;
      n/=d;
    }

C☺DE

#include <iostream>
#include <cmath>

using namespace std;

bool isPrime(int n)
{
    int m = sqrt(n);
    if (n == 1) return false;
    for (int i = 2; i <= m; ++i)
        if (n % i == 0)
            return false;
    return true;
}

int main()
{
    int n, d;
    cin >> n;
    while (n > 0)
    {
        cin >> d;
        if (!isPrime(n))
            cout << "No" << endl;
        else
        {
            int rn = 0;
            while (n > 0)
            {
                rn = rn * d + n % d;
                n /= d;
            }
            cout << (isPrime(rn) ? "Yes" : "No") << endl;
        }
        cin >> n;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值