PAT 甲1059

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1​k1​×p2​k2​×⋯×pm​km​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1​^k1​*p2​^k2​**pm​^km​, where pi​'s are prime factors of N in increasing order, and the exponent ki​ is the number of pi​ -- hence when there is only one pi​, ki​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

Solution

#include <stdio.h>
#include <math.h>
#define max 10000001

int prime[max],pcnt=0;
bool a[max]={false};

void Find_prime(){
	for(int i=2;i<max;i++){
		if(a[i]==false){
			prime[pcnt++]=i;
		}
		for(int j=i+i;j<max;j+=i){
			a[j]=true;
		}
	}
}

struct factor{
	int x,cnt;
}fac[10];

int main(){
	long long n;
	int num=0;
	scanf("%lld",&n);
	Find_prime();
	if(n==1) printf("1=1");
	else{
		printf("%d=",n);
		int sqr=(int)sqrt(1.0*n);
		for(int i=0;i<pcnt&&prime[i]<=sqr;i++){
			if(n%prime[i]==0){
				fac[num].x=prime[i];
				fac[num].cnt=0;
				while(n%prime[i]==0){
					fac[num].cnt++;
					n/=prime[i];
				}
				num++;
			}
			if(n==1) break;
		}
		if(n!=1){
			fac[num].x=n;
			fac[num++].cnt=1;
		}
		for(int i=0;i<num;i++){
			if(i>0) printf("*");
			printf("%d",fac[i].x);
			if(fac[i].cnt>1){
				printf("^%d",fac[i].cnt);
			}
		}
	}
	return 0;
}

1、一个数的质因子只可能有两种情况     全部小于sqrt(n)  或者 最多只有一个大于sqrt

2、要注意  1=1 这个特殊情况

3、当prime[i]> or >=sqrt(n)时,说明小的已经找完了,该找大的数

4、   注意这里的 num++   逻辑是先用了,再加一

5、 所以这里 第一个for循环才可以用 i<num(因为num多了一个)

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值