2018.1.20【HDU - 1027】解题报告(排列STL)

11 篇文章 0 订阅

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9305    Accepted Submission(s): 5446


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input
 
 
6 4
11 8
 

Sample Output
 
 
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
 

Author
Ignatius.L

【解题思路】
利用C++STL中的next_permutation()函数实现对数组排列,调用m-1次该函数然后按格式输出即可。
【解题代码】
#include <iostream> 
#include <algorithm>
#include <string>
#include <stack>
#include <vector>
#define maxn 100010
using namespace std;
int a[maxn];
int main()
{
	int n,m;
	while(cin>>n>>m)
//	cin>>n>>m;
{
		for(int i=0;i<n;i++)
		{
			a[i]=i+1;
		}
//		vector<int> v1(a,a+n);					没有利用上vector 待补充 
//		vector<int>::iterator p=v1.begin();
	int count=m-1;								//设置计数器 
		do								//注意使用dowhile 
		{
//			for(int j=0;j<n;j++)
//				cout<<a[j]<<" ";
//			cout<<endl; 
			count--;
		}while(next_permutation(a,a+n)&&count);
	for(int j=0;j<n-1;j++)
		cout<<a[j]<<" ";
	cout<<a[n-1]<<endl; 						//输出格式最后一个数后面没有空格 
}
	return 0;
}
【收获和反思】
刚刚接触C++和STL,很生疏,需要尽快熟悉这些代码标准以及一些基本的STL应用。
对于next_permutation函数的一点深入了解。和next_permutation类似,还有一个prev_permutation函数。前者是求下一个排列,后者是上一个排列。
相关的函数原型如下:

函数实现原理如下:

在当前序列中,从尾端往前寻找两个相邻元素,前一个记为*i,后一个记为*ii,并且满足*i < *ii。然后再从尾端寻找另一个元素*j,如果满足*i < *j,即将第i个元素与第j个元素对调,并将第ii个元素之后(包括ii)的所有元素颠倒排序,即求出下一个序列了。



图片来源:http://blog.csdn.net/c18219227162/article/details/50301513
再接再厉。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值