2018.4.10【 HDU - 2035 】解题报告(快速幂,水题)

6 篇文章 0 订阅

人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 50694    Accepted Submission(s): 33834


Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
 

Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 

Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
 

Sample Input
 
 
2 3 12 6 6789 10000 0 0
 

Sample Output
 
 
8 984 1
 

Author
lcy
 

Source
 

Recommend
lcy

1.题目大意

如题

2.解题思路

快速幂模1000即可

3.解题代码

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <set>
#include <map>
#include <queue>
#include <vector>
#include <string>
#define f(i,n) for(int i=0;i<n;i++)
using namespace std;
const int maxn=1e5+5;
const int MAXN=0x3f3f3f;
const int maxn2=1e3+5;
int qpow(int a,int b,int m)
{
	int ans=1;
	while(b)
	{
		if(b&1) ans=(ans*a)%m;
		b/=2;
		a=(a*a)%m;
	}
	return ans;
}
int main()
{
	int mod=1000;
	int a,b;
	while(~scanf("%d%d",&a,&b)&&a+b)
	{
		a%=mod;
		printf("%d\n",qpow(a,b,mod));
		
	}
	return 0;
}

4.收获与反思

快速幂温习水题。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值