Raising Modulo Numbers
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 9545 | Accepted: 5807 |
Description
People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:
Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bifrom all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.
You should write a program that calculates the result and is able to find out who won the game.
Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bifrom all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.
You should write a program that calculates the result and is able to find out who won the game.
Input
The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.
Output
For each assingnement there is the only one line of output. On this line, there is a number, the result of expression
(A1B1+A2B2+ ... +AHBH)mod M.
Sample Input
3 16 4 2 3 3 4 4 5 5 6 36123 1 2374859 3029382 17 1 3 18132
Sample Output
2 13195 13
Source
1.题目大意
给出数组A[]和数组B[],求ΣAi^Bi 模m的值。
2.解题思路
快速幂求Ai^Bi
3.解题代码
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <set>
#include <algorithm>
#include <queue>
#include <string>
#include <iomanip>
#define f(i,n) for(int i=0;i<n;i++)
using namespace std;
const int maxn=5e4+5;
const int MAXN=0x3f3f3f;
typedef long long ll;
int qpow(int a, int b, int mod)
{
int ans=1;
while(b)
{
if(b&1) ans=(ans*a)%mod;
b/=2;
a=(a*a)%mod;
}
return ans;
}
int ai[maxn],bi[maxn],m;
int main()
{
int z,h;
scanf("%d",&z);
while(z--)
{
int ans=0;
scanf("%d%d",&m,&h);
f(i,h)
{
scanf("%d%d",&ai[i],&bi[i]);
ai[i]%=m; //可以预处理一下
ans=(ans+qpow(ai[i],bi[i],m))%m;
}
printf("%d\n",ans);
}
}
4.收获与反思
快速幂学习,原文:点击打开链接
个人理解:
A^N%C的运算,朴素算法进行N次乘法,再对C取模。
朴素算法的问题:
1.O(n)的算法,时间复杂度不友好,底数较大时更加明显。
2.并且A^N数据过大,计算机无法存储。
快速幂算法步骤:
将N表示为二进制形式 N=b0*2^0+b1*2^1+b2*2^2+......bn*2^n;
则A^N=A^(b0*2^0)*A^(b1*2^1)*......*A^(bn^2^n)
根据模运算的性质,等式两边同时模m,则等式右边可先计算每个部分 (A^(bi*2^i)%m) ,
并且可以发现每个部分比前一个部分A都倍增了一次,即循环计算A=A*A%m.
还有当bi为0时,明显子部分值为1,即可以跳过。
算法:
ans=1; //记录结果
a=a%c; //预处理,使得a处于c的数据范围之下
while(b!=0)
{
if(b&1) ans=(ans*a)%c; //如果b的二进制位不是0,那么我们的结果是要参与运算的
b>>=1; //二进制的移位操作,相当于每次除以2,用二进制看,就是我们不断的遍历b的二进制位
a=(a*a)%c; //不断的加倍
}
最后return ans。
下面为qpow完整模板(注意有时需要 long long)。
ll qpow(ll a, ll b, ll mod)
{
ll ans=1;
while(b)
{
if(b&1) ans=(ans*a)%mod;
b/=2;
a=(a*a)%mod;
}
return ans;
}