2018.2.4【 HDU - 1789 】解题报告(贪心)

4 篇文章 0 订阅

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15959    Accepted Submission(s): 9294


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
 

Source
 

Recommend
lcy

【题目大意】

做作业,每一份作业有ddl和score(不按期完成减掉的分数)两个属性,给出n份作业的两个属性,求最少的扣分。

【解题思路】

贪心,我们尽量保证让分值大的作业按期完成,相同考虑相同分值大的安排ddl小的(避免先安排ddl大的占据了ddl小的位置,而ddl大的有多种选择)。这样按照score较大,相同score则ddl较小的优先的方式排序,然后从ddl日期逐步往前推(尽量先占后面的日期),如果找不到安排该作业的时间,则扣分加上该作业的score值。

【解题代码】

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
using namespace std;
const int maxn=1e5+10;
struct node 
{
	int ddl;
	int score;
}a[maxn];
int vis[maxn];
bool cmp(node a,node b)
{
	if(a.score!=b.score) return a.score>b.score;
	else return a.ddl<b.ddl; 
} 
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		memset(vis,0,sizeof(vis)); 
		for(int i=0;i<n;i++)
			scanf("%d",&a[i].ddl);
		for(int i=0;i<n;i++)
			scanf("%d",&a[i].score);
		sort(a,a+n,cmp);
		int sum=0;
		for(int i=0;i<n;i++)
		{
			int j=a[i].ddl;
				for(;j>0;j--)
				{
					if(!vis[j])
					{
						vis[j]=1;
						break;
					}
				}
				if(!j)	sum+=a[i].score;
		} 
		printf("%d\n",sum);
	} 
	return 0;
	
	
 } 

【收获与反思】

贪心策略,优先分值大的,并且优先安排日期靠后的位置(这一步学习一下)。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值