HDU 1028 Ignatius and the Princess III(递推)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22918    Accepted Submission(s): 15987


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+…+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4
10
20
 

Sample Output
  
  
5
42
627
 

Author
Ignatius.L
 

Recommend
 

Statistic |  Submit |  Discuss | Note




题意

    这题……其实就是整数拆分,每次给你一个整数,问你能有几种方法把它拆分成若干个整数的和

思路

    这题..就是递推就行了,不过要加一个记忆化。递推的时候,我们传入两个参数n,m,表示现在分到n这个数,而可行的最大加数为m。这样我们可以得到三种情况:

(1) m>n
    这种情况我们直接转移到dfs(n,n)就行了,因为最大加数不能大于n
(2) m=n
    这种情况我们可以转移到1+dfs(n,m-1),可以看出最大加数为m=n的时候只有一种情况,然后再是递归下去。
(3) m<n
    这种情况的话,我们就是分为dfs(n-m,m)+dfs(n,m-1),可以看出就是最大加数为m和整数n-m的划分的和。

最后我们只需要每次递归的时候做一下记忆化就行了。

Code

#pragma GCC optimize(3)
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cctype>
#include<climits>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<stack>
#include<climits>
#include<vector>
using namespace std;
typedef long long ll;
inline void readInt(int &x) {
    x=0;int f=1;char ch=getchar();
    while(!isdigit(ch)){if(ch=='-')f=-1;ch=getchar();}
    while(isdigit(ch))x=x*10+ch-'0',ch=getchar();
    x*=f;
}
inline void readLong(ll &x) {
    x=0;int f=1;char ch=getchar();
    while(!isdigit(ch)){if(ch=='-')f=-1;ch=getchar();}
    while(isdigit(ch))x=x*10+ch-'0',ch=getchar();
    x*=f;
}
/*================Header Template==============*/
int n;
ll ans,f[150][150];
inline ll dfs(int n,int m) {
    if(~f[n][m])
        return f[n][m];
    if(n==1||m==1)
        return f[n][m]=1;
    else if(n<m)
        return f[n][m]=dfs(n,n);
    else if(n==m)
        return f[n][m]=dfs(n,n-1)+1;
    else
        return f[n][m]=dfs(n,m-1)+dfs(n-m,m);
}
int main() {
    memset(f,-1,sizeof f);
    while(scanf("%d",&n)==1)
        printf("%d\n",dfs(n,n));
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值