【题解】【PAT甲】1147 Heaps (30 分)(堆)

27 篇文章 0 订阅

题目链接

PTA | 程序设计类实验辅助教学平台

题目描述

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

结尾无空行

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

结尾无空行

题目大意

给你一个完全二叉树的层序遍历,让你判断是大顶堆小顶堆还是不是堆,然后输出后序遍历的序列

解题思路

一开始思路被判断大顶堆小顶堆卡住了,然后参考柳婼代码

PAT 1147. Heaps (30) - 甲级_柳婼 の blog-CSDN博客

层序遍历完全二叉树可以用数组表示,从下标1开始,左子树就是父节点下标*2,右节点就是父节点下标*2+1,父节点就是本节点/2

主要还是判断大顶堆小顶堆,可以设两个变量一开始初始为true,一个代表是大顶堆,一个代表是小顶堆,如果不满足直接置于false,最后判断哪个是true就说明是哪个堆,如果两个都为false说明不是堆

题解

#include<bits/stdc++.h>
using namespace std;
vector<int> v;
int m,n;
int c=0;
void dfs(int x){
	if(x>n)	return ;
	dfs(x*2);
	dfs(x*2+1);
	if(c==0)	c=1;
	else printf(" ");
	printf("%d",v[x]);
}
int main(){
	cin>>m>>n;
	v.resize(n+1);
	while(m--){
		v.clear();
		int mmax=1;
		int mmin=1;
		for(int i=1;i<=n;i++){
			scanf("%d",&v[i]);
		}
		for(int i=2;i<=n;i++){
			if(v[i]>v[i/2])	mmax=0;
			if(v[i]<v[i/2])	mmin=0;
		}
		if(mmax==1)	printf("Max Heap\n");
		else if(mmin==1)	printf("Min Heap\n");
		else	printf("Not Heap\n");
		c=0;
		dfs(1);
		printf("\n");
	} 
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值