1147. Heaps (30)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 100), the number of trees to be tested; and N (1 < N <= 1000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line “Max Heap” if it is a max heap, or “Min Heap” for a min heap, or “Not Heap” if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10


题目大意:
给定m棵有n个结点的完全二叉树的层次遍历序列。判断该序列是否为堆,是最大堆还是最小堆。并且输出该树的后序遍历结果。

题目思路:
我们将根结点的编号设为1,左孩子的结点编号就是2*1 = 2,有孩子结点编号就是2*1+1 = 3,如果某结点编号为i,那么该结点左孩子编号为2*i,右孩子结点编号为2*i+1,

因此,我们可以通过结点编号对这棵树进行深度优先搜索并且先右,我们就可以求出后序遍历的结果。

至于判断是否是最大堆,我们设置isHeap = -1 用于表示不知道是什么堆。如果父亲结点比孩子结点大,并且isHeap == -1那么就设置isHeap = 1,如果isHeap == 2说明发生冲突,设置isHeap = 0 表示该树不是堆。如果父亲结点比孩子结点小,同理。

因为给定的结点的值都不相同,所以对于等于的情况不需要考虑。


#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;

int n, m, val, isHeap;
vector<int>v, post;

void getPost(int root) {
    if (root*2 < v.size()){
        if (v[root] > v[root*2]) {
            if (isHeap == -1) {
                isHeap = 1;
            } else if (isHeap == 2) {
                isHeap = 0;
            }
        }
        if (v[root] < v[root*2]) {
            if (isHeap == -1) {
                isHeap = 2;
            } else if (isHeap == 1) {
                isHeap = 0;
            }
        }
        getPost(root*2);
    } 
    if (root*2+1 < v.size()) {
        if (v[root] > v[root*2+1]) {
            if (isHeap == -1) {
                isHeap = 1;
            } else if (isHeap == 2) {
                isHeap = 0;
            }
        }
        if (v[root] < v[root*2+1]) {
            if (isHeap == -1) {
                isHeap = 2;
            } else if (isHeap == 1) {
                isHeap = 0;
            }
        }
        getPost(root*2+1);
    }
    post.push_back(v[root]);
}

int main() {
    scanf("%d%d", &m, &n);
    for (int i = 0; i < m; i++) {
        isHeap = -1;
        v.clear();
        v.push_back(-1);
        post.clear();
        for (int j = 0; j < n; j++) {
            scanf("%d", &val);
            v.push_back(val);
        }
        getPost(1);
        if (isHeap == 0) {
            printf("Not Heap\n");
        } else if (isHeap == 1) {
            printf("Max Heap\n");
        } else {
            printf("Min Heap\n");
        }
        for (int i = 0; i < post.size(); i++) {
            if (i != 0) printf(" ");
            printf("%d", post[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值