Heaps

                                            7-4 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

思路:将n个值存放到heap数组,对树进行遍历将从跟到所有叶子节点的路径存放到二维数组ans里面,然后对每一条路径进行遍历 ,如果所有路径都是递增的,说明是Min Heap,如果所有的路径都是递减的,说明是Max Heap,否则就是Not Heap。然后对树进行后序遍历,输出

上AC代码:

#include <iostream>
#include<bits/stdc++.h>
using namespace std;
int m,n,heap[1001];
vector< vector<int> > ans;
void dfs(int index,vector<int> v)
{
    if(index>n)
        return;
    v.push_back(heap[index]);
    if(2*index>n)
    {
        ans.push_back(v);
    }
    dfs(2*index,v);
    dfs(2*index+1,v);
    v.pop_back();
}
int judge(vector<int> v)
{
    int sum=0;
    for(int i=1;i<v.size();i++)
        if(v[i] >v[i-1])
        sum++;
    if(sum==v.size()-1)
        return 1;///大
    sum=0;
    for(int i=1;i<v.size();i++)
        if(v[i] <v[i-1])
        sum++;
    if(sum==v.size()-1)
        return -1;///xiao
    return 0;///not
}
void post(int index,vector<int> &ans)
{
    if(index>n)
        return ;
    post(2*index,ans);
    post(2*index+1,ans);
    ans.push_back(heap[index]);
}
int main()
{
    cin>>m>>n;
    for(int i=1;i<=m;i++)
    {
        ans.clear();
        for(int j=1;j<=n;j++)
            cin>>heap[j];
        vector<int> v;
        dfs(1,v);
        int num1=0,numfu=0;
        for(int j=0;j<ans.size();j++)
        {
            if(judge(ans[j])==1)
                num1++;
            else if(judge(ans[j])==-1)
                numfu++;
        }
        if(num1==ans.size())
            cout<<"Min Heap"<<endl;
        else if(numfu==ans.size())
            cout<<"Max Heap"<<endl;
        else
            cout<<"Not Heap"<<endl;
        vector<int> h;
        post(1,h);
        for(int j=0;j<h.size();j++)
        {
            cout<<h[j];
            if(j==h.size()-1)
                cout<<endl;
            else
                cout<<" ";
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值