九度[1043]-Day of Week

九度[1043]-Day of Week

题目描述:
We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入
There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出
Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入
9 October 2001
14 October 2001

样例输出
Tuesday
Sunday

提示
Month and Week name in Input/Output:
January, February, March, April, May, June, July, August, September, October, November, December
Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday

解题思路:
公元1年的1月1日是周日

AC代码:

#include <cstdio>
#include <cstring>
int d, y;
char m[20];
char month[13][20] = {"", "January", "February", "March", "April", "May", "June",\
 "July", "August", "September", "October", "November", "December"};
int daysM[13] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
char weekDay[8][20] = {"", "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"};

bool isLeap(int n){
    if(n % 400 == 0 || (n % 4 == 0 && n % 100 != 0)) return true;
    else return false;
}

int calDay(int d, char m[], int y){
    int days, index = 0;
    for(int i = 1; i < y; i++){
        if(isLeap(i)) days += 366;
        else days += 365;
    }
    for(int i = 1; i <= 12; i++){
        if(strcmp(month[i], m) == 0){
            index = i;
            break;
        }
    }
    for(int i = 1; i < index; i++){
        days += daysM[i];
        if(i == 2 && isLeap(y)) days += 1; // leap year February 29 days
    }
    days += d;
    return days % 7 + 1;
}

int main(){
    freopen("C:\\Users\\Administrator\\Desktop\\test.txt", "r", stdin);
    while(scanf("%d%s%d", &d, m, &y) != EOF){
        printf("%s\n", weekDay[calDay(d, m, y)]);
    }
    fclose(stdin);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值