PAT [A1060]-Are They Equal

PAT [A1060]-Are They Equal

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:
For each test case, print in a line “YES” if the two numbers are treated equal, and then the number in the standard form “0.d1…dN*10^k” (d1>0 unless the number is 0); or “NO” if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3

解题思路:
字符串操作,注意0.0, 0.001等数据
sprintf可以将数字传进对应的char数组,然后再转入string中

AC代码:

#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
using namespace std;
const int maxn = 110;
int N;
string A, B;

string trans(int N, string dat){
    string ans = "", sub = "";
    int pPos = dat.length(), nPos = -1, lenT = dat.length();
    // 定位小数点与第一个非0数字的位置
    for (int i = 0; i < dat.length(); i++){
        if (dat[i] == '.') {
            pPos = i;
            break;
        }
    }
    for (int i = 0; i < dat.length(); i++){
        if (dat[i] != '0' && dat[i] != '.') {
            nPos = i;
            break;
        }
    }
    // 若位数目不够,则补0
    if (lenT - nPos - 1 < N){
        for (int i = 0; i < (N - lenT - nPos + 1); i++){
            dat += "0";
        }
    }
    // 输入为0
    if (nPos == -1) {
        for (int i = 0; i < N; i++){
            sub += "0";
        }
        ans = "0." + sub + "*10^0";
    }
    // 输入不为0
    else{
        int len = pPos - nPos;
        // 如果len>0,代表整数部分不为0
        if (len > 0){
            // 若无小数点或截取部分没有超出整数部分,则只截取整数部分, 否则还需要截取小数部分
            if (pPos == lenT || N <= len) sub = dat.substr(nPos, N);
            else{
                sub = dat.substr(nPos, len) + dat.substr(pPos + 1, N - len);
            }
        }
        // 如果len<0,代表整数部分为0,应为10的(len+1)次方
        else{
            len += 1;
            sub = dat.substr(nPos, N);
        }
        // 将数组传进string
        char lenS[maxn];
        sprintf(lenS, "%d", len);
        string lenStr = lenS;
        ans = "0." + sub + "*10^" + lenS;
    }
    return ans;
}

int main(){
    freopen("C:\\Users\\Administrator\\Desktop\\test.txt", "r", stdin);
    while (scanf("%d", &N) != EOF){
        cin >> A >> B;
        //cout << A << " "<< B << endl;
        string ansA = trans(N, A), ansB = trans(N, B);
        if (ansA == ansB) cout << "YES " << ansA << endl;
        else cout << "NO " << ansA << " " << ansB << endl;
    }
    fclose(stdin);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值