POJ2378(树形DP)

Description

After Farmer John realized that Bessie had installed a “tree-shaped” network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.

Bessie, feeling vindictive, decided to sabotage Farmer John’s network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

  • Line 1: A single integer, N. The barns are numbered 1..N.

  • Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

  • Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word “NONE”.

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

Hint

INPUT DETAILS:

The set of connections in the input describes a “tree”: it connects all the barns together and contains no cycles.

OUTPUT DETAILS:

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

题意:一个人把一个农场的电力系统搞成了树状结构,如果切断一个节点的电,则这个点连接的所有电路都断了,这样就把整个电力系统切成了几大部分,问你切哪些点可以让这个电力系统被切后的几大部分的最大节点数不超过原电力系统的总结点数的一半。

题解:这道题用树状dp做。先用用树状数组建一个树,然后就可以开始愉快的递推了。dp[u]代表去掉u节点后节点数最多的树的节点数。可以有两部分来源,一部分是来源于此节点的子节点的树的节点数,另一部分是来源于此节点的除子节点的树以外的所有节点构成的树。
dp[u]=max(n - sum, ans);//n为总节点数,sum为所有子节点的树中的节点总和,ans为所有子节点的树中节点数最多的树的节点数。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>

using namespace std;

const int maxn = 10002;
vector<int> p[maxn];
int dp[maxn] = {0}, n;

int dfs(int u, int fa)
{
    int sum = 1, ans = 0, maxans = 0;
    int l = p[u].size();
    for (int i = 0; i < l; i++) {
        int v = p[u][i];
        if (v == fa) continue;
        ans = dfs (v, u);
        sum += ans;
        maxans = max (maxans, ans);
    }
    dp[u] = max (maxans, n - sum);
    return sum;
}

int main()
{
    int flag = 0;
    scanf ("%d", &n);
    for (int i = 1; i < n; i++) {
        int a, b;
        scanf ("%d%d", &a, &b);
        p[a].push_back(b);//由于是无向图,所以两个方向都要存储
        p[b].push_back(a);
    }
    dfs (1, 0);
    for (int i = 1; i <= n; i++) {
        if (dp[i] * 2 <= n) {
            flag = 1;
            printf ("%d\n", i);
        }
    }
    if (!flag) {
        printf ("NONE\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值