Power of Cryptography(POJ 2109)(二分)

题目链接:http://poj.org/problem?id=2109
Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n th. power, for an integer k (this integer is what your program must find).
Input
The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10 101 and there exists an integer k, 1<=k<=10 9 such that k n = p.
Output
For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.
Sample Input
2 16
3 27
7 4357186184021382204544
Sample Output
4
3
1234

题解:输入n、p,要求k使k^n=p。k有范围,而且算是单调的。
所以可以用二分法,去查找k。
思考:要相信自己,要自己试一试。

#include <iostream>
#include <cmath>

using namespace std;

const int maxn = 1000000000;
double n, p;

int BinarySearch(int low, int high)
{
    while (low <= high) {
        int mid = (low + high) >> 1;
        double now = pow (mid, n);
        if (now == p) return mid;
        else if (now > p) high = mid - 1;
        else if (now < p) low = mid + 1;
    }
    return -1;
}

int main()
{
    while (cin >> n >> p) {
        int k = BinarySearch (0, maxn);
        cout << k << endl;
    }
    return 0;
}

PS:这道题的数据很水,所以直接用double和pow就可以了。

#include <iostream>
#include <cmath>

using namespace std;

int main()
{
    double n, p;
    while (cin >> n >> p) {
        cout << pow (p, 1 / n) << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值