杭电ACM题1001的超时问题

Ignatius and the Princess IV

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32767K (Java/Other)
Total Submission(s) : 65   Accepted Submission(s) : 17
Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?


 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.


 

Output

For each test case, you have to output only one line which contains the special number you have found.


 

Sample Input
  
  
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1


 

Sample Output
  
  
3 5 1

///

简单题,做的时候出现了超时问题,问题是由于cin造成的,用cin输入num会出现超时,但通过scanf函数接受num时可以AC,这个不明白,刚开始学C++,对它的输入输出不是很了解。

//

代码:

/***********************
*   程序名:Ignatius and the Princess IV.cpp
*   功能:ACM
************************/
#include <iostream>
#include <Cstdio>

using namespace std;

int main()
{
    int N, num, temp, i;
    while(scanf("%d", &N) != EOF) {
        int count[32768] = {0};
        for(i = 0; i < N; i++) {
            scanf("%d", &num);
            count[num]++;
            if(count[num] >= (N+1)/2) {
                temp = num;
            }
        }
        cout<<temp<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值