Heritage from father

79 篇文章 0 订阅

Problem   Link:http://acm.hdu.edu.cn/showproblem.php?pid=1178


原题:




Heritage from father

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 5074    Accepted Submission(s): 1793


Problem Description
Famous Harry Potter,who seemd to be a normal and poor boy,is actually a wizard.Everything changed when he had his birthday of ten years old.A huge man called 'Hagrid' found Harry and lead him to a new world full of magic power. 
If you've read this story,you probably know that Harry's parents had left him a lot of gold coins.Hagrid lead Harry to Gringotts(the bank hold up by Goblins). And they stepped into the room which stored the fortune from his father.Harry was astonishing ,coz there were piles of gold coins. 
The way of packing these coins by Goblins was really special.Only one coin was on the top,and three coins consisted an triangle were on the next lower layer.The third layer has six coins which were also consisted an triangle,and so on.On the ith layer there was an triangle have i coins each edge(totally i*(i+1)/2).The whole heap seemed just like a pyramid.Goblin still knew the total num of the layers,so it's up you to help Harry to figure out the sum of all the coins.
 

Input
The input will consist of some cases,each case takes a line with only one integer N(0<N<2^31).It ends with a single 0.
 

Output
对于每个输入的N,输出一行,采用科学记数法来计算金币的总数(保留三位有效数字)
 

Sample Input
  
  
1 3 0
 

Sample Output
  
  
1.00E0 1.00E1
Hint
Hint
when N=1 ,There is 1 gold coins. when N=3 ,There is 1+3+6=10 gold coins.
 

Source
 

解题思路:

求Sn=(1*2+2*3+....+n*(n+1))/2;

因为n*(n+1)=n^2+n,又1^2+2^2+3^2+...+n^2=n(n+1)(2n+1)/6  1+2+3+...+n=n(n+1)/2;

所以S=[n(n+1)(2n+1)/6+n(n+1)/2]/2=n(n+1)(n+2)/6;

科学计数法没办法直接按要求输出,得直接求出指数


code  1:

------------------------------------------------------------------------------------------------------------------------------------------------

#include <stdio.h>
int main ()
{
int n,c;
double sum;
while (scanf("%d",&n)!=EOF)
{
   if (n==0)break;
   sum=1.0/6*n*(n+2)*(n+1);
   c=0;
   while (sum>=10)
   {
    c++;
    sum/=10;
   }
   printf ("%.02lfE%d\n",sum,c);
}
return 0;
}



------------------------------------------------------------------------------------------------------------------------------------------------------

code  2:

#include<stdio.h>
#include<math.h>
int main()
{
 int m,i;
 double n,sum;
 while(scanf("%lf",&n)!=-1,n)
 {
        sum=(n*(n+1)*(2*n+1)/6+n*(n+1)/2)/2;
  m=(int)log10(sum);
  for(i=1;i<=m;i++)
   sum*=0.1;
  printf("%.2fE%d\n",sum,m);
 }
 return 0;
}


 -------------------------------------------------------------------------------------------------------------------------------------------


code  3:

这是我自己写的代码,不知为何在hdu  oj 上是wa,没通过。求路过的大神指点一下。。。可怜


#include<stdio.h>
#include<math.h>
int main()
{
int m,n;
double a,x;
while(scanf("%d",&n)!=EOF)
{
if(n==0)
break;
x=log10(n*1.0/6)+log10((n+1)*1.0)+log10((n+2)*1.0);
m=(int)x;
a=pow(10.0,x-(int)x);
printf("%.02lfE%d\n",a,m);
}
return 0;
}


--------------------------------------------------------------------------------------------------------------------------------------------

类似应用这种思想求解的还有一题:leftmost  digit,可在文章名搜一下。。。




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值