Rescue(逆向BFS)

171 篇文章 0 订阅
99 篇文章 0 订阅

Link:http://acm.hdu.edu.cn/showproblem.php?pid=1242

Problem:

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16584    Accepted Submission(s): 6025


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
 

code:


#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
char map[201][201];
int vis[201][201],ex,ey,n,m;
int d[4][2]={{-1,0},{0,-1},{1,0},{0,1}};
struct node{
int x;
int y;
int step;
};
int bfs()
{
queue<node>Q;
memset(vis,0,sizeof(vis));
int i,xi,yi;
node now,next;
now.step=0;
now.x=ex;
now.y=ey;
Q.push(now);
vis[ex][ey]=1;
while(!Q.empty())
{
now=Q.front();
Q.pop();
if(map[now.x][now.y]=='r')
return now.step;
for(i=0;i<4;i++)
{
xi=now.x+d[i][0];
yi=now.y+d[i][1];
if(xi>=0&&xi<n&&yi>=0&&yi<m&&!vis[xi][yi]&&map[xi][yi]!='#')
{
vis[xi][yi]=1;
next.x=xi;
next.y=yi;
if(map[xi][yi]=='x')
next.step=now.step+2;
else
next.step=now.step+1;
Q.push(next);
}
}
}
return -1;
}
int main()
{
int i,j,fg;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=0;i<n;i++)
{
scanf("%s",map[i]);
for(j=0;j<m;j++)
{
 if(map[i][j]=='a')
{
ex=i;
ey=j;
}
}
}
fg=bfs();
if(fg==-1)
printf("Poor ANGEL has to stay in the prison all his life.\n");
else
printf("%d\n",fg);
}
return 0;
}

总结:此题注意可能有多个’r’,而’a’只有一个,从’a’开始搜,找到的第一个’r’即为所求

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值