线段树区间修改与区间增减的区别(个人总结)

171 篇文章 0 订阅
73 篇文章 0 订阅


用两个例子说明:

Link:http://acm.hdu.edu.cn/showproblem.php?pid=1698


Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19079    Accepted Submission(s): 9575


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:   1542  1255  1828  1540  3397 
 


成段更新(通常这对初学者来说是一道坎),需要用到延迟标记(或者说懒惰标记),简单来说就是每次更新的时候不要更新到底,用延迟标记使得更新延迟到下次需要更新or询问到的时候。




区间修改:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<queue>
#define MAXN 100010
#define LL long long
using namespace std;
struct node{
	int l,r;
	LL tag;//存储懒惰记录的数值 (要改变的值) 
	LL s;
}tree[MAXN*4];

void build(int rt,int s,int e)
{
	tree[rt].l=s;
	tree[rt].r=e;
	tree[rt].tag=0;
	if(s==e)
	{
		tree[rt].s=1;
		return;//记得return 
	}
	int mid=(s+e)/2;
	build(rt*2,s,mid);
	build(rt*2+1,mid+1,e);
	tree[rt].s=tree[rt*2].s+tree[rt*2+1].s;//回溯 
}
void update(int rt,int ul,int ur,int val)
{
	if(tree[rt].l==ul&&tree[rt].r==ur)
	{
		tree[rt].tag=val;//存储懒惰记录的数值 
		tree[rt].s=(ur-ul+1)*val;
		return;//记得return 
	}
	int mid=(tree[rt].l+tree[rt].r)/2;
	if(tree[rt].tag!=0)//因为下面需要回溯,且每次更新的区间可能不同,即递归深搜的路径长度(树的遍历深度)不一样,
	//但回溯时路径总会有重合的部分,这样就会影响正确结果,故需要把该节点未更新的子区间也更新 
	{
		update(rt*2,tree[rt].l,mid,tree[rt].tag);
    	update(rt*2+1,mid+1,tree[rt].r,tree[rt].tag);
     	tree[rt].tag=0;//懒惰记录的数值传给下面子区间的节点了,故取消懒惰记录的数值
	}
	if(mid>=ur) update(rt*2,ul,ur,val);
	else if(mid<ul) update(rt*2+1,ul,ur,val);
	else
	{
		update(rt*2,ul,mid,val);
		update(rt*2+1,mid+1,ur,val);
	}
	tree[rt].s=tree[rt*2].s+tree[rt*2+1].s;//回溯 
}
int main()
{
	int t,x,y,z,cas,n,q;
	scanf("%d",&t);
	cas=0;
	while(t--)
	{
		cas++;
		scanf("%d",&n);
		build(1,1,n);
		scanf("%d",&q);
		while(q--)
		{
			scanf("%d%d%d",&x,&y,&z);
			update(1,x,y,z);
		}
		printf("Case %d: The total value of the hook is %lld.\n",cas,tree[1].s);
	}
	return 0;
 } 


Link:http://poj.org/problem?id=3468


A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 68421 Accepted: 21091
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source



区间增减:


#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<cstdio>
#define LL long long
#define MAXN  100010
using namespace std;
struct node{
	int l,r;
	LL tag;
	LL  sum;
}tree[MAXN*4];
int a[MAXN];
void build(int rt,int l,int r)
{
	tree[rt].l=l;
	tree[rt].r=r;
	tree[rt].tag=0;
	if(l==r)
	{
		tree[rt].sum=a[l];
		return;
	}
	int mid=(l+r)/2;
    build(rt*2,l,mid);
    build(rt*2+1,mid+1,r);
    tree[rt].sum=tree[rt*2].sum+tree[rt*2+1].sum;	
}
void update(int rt,int ul,int ur,LL v)
{
	if(tree[rt].l==ul&&tree[rt].r==ur)
	{
		tree[rt].tag+=v;
		//tree[rt].sum+=v*(ur-ul+1);
		return;
	}
	tree[rt].sum+=v*(ur-ul+1);
	int mid=(tree[rt].l+tree[rt].r)/2;
	//因为不需要回溯, 
	/*if(tree[rt].tag!=0)
	{
		update(rt*2,tree[rt].l,mid,tree[rt].tag);
		update(rt*2+1,mid+1,tree[rt].r,tree[rt].tag);
		tree[rt].tag=0;
	}*/
	if(mid>=ur) update(rt*2,ul,ur,v);
	else if(mid<ul) update(rt*2+1,ul,ur,v);
	else
	{
		update(rt*2,ul,mid,v);
		update(rt*2+1,mid+1,ur,v);
	}
	//不需要回溯 
}
LL query(int rt,int l,int r)
{
	if(tree[rt].l==l&&tree[rt].r==r)
	{
		return tree[rt].sum+(r-l+1)*tree[rt].tag;
	}
	tree[rt].sum+=(tree[rt].r-tree[rt].l+1)*tree[rt].tag;
	int mid=(tree[rt].l+tree[rt].r)/2;
	//update(rt*2,tree[rt].l,mid,tree[rt].tag);
	//update(rt*2+1,mid+1,tree[rt].r,tree[rt].tag);
	//tree[rt].tag=0;
		if(tree[rt].tag!=0)//因为下面需要回溯,且每次更新的区间可能不同,即递归深搜的路径长度(树的遍历深度)不一样,
	//但回溯时路径总会有重合的部分,这样就会影响正确结果,故需要把该节点未更新的子区间也更新 
	{
		update(rt*2,tree[rt].l,mid,tree[rt].tag);
    	update(rt*2+1,mid+1,tree[rt].r,tree[rt].tag);
     	tree[rt].tag=0;//懒惰记录的数值传给下面子区间的节点了,故取消懒惰记录的数值
	}
	if(r<=mid) return query(rt*2,l,r);
	else if(l>mid)  return query(rt*2+1,l,r);
	else{
		return query(rt*2,l,mid)+query(rt*2+1,mid+1,r);
	}
}
int main()
{
	int n,q,x,y,z,i;
	char ch;
	while(scanf("%d%d",&n,&q)!=EOF)
	{
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		build(1,1,n);
		while(q--)
		{
			cin>>ch;
			if(ch=='Q')
			{
				scanf("%d%d",&x,&y);
				
				printf("%lld\n",query(1,x,y));
			}
			else
			{
				scanf("%d%d%d",&x,&y,&z);
				update(1,x,y,z);
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值