hdu5327 Olympiad(简单题:打表+模拟)

173 篇文章 3 订阅
171 篇文章 0 订阅


Link:http://acm.hdu.edu.cn/showproblem.php?pid=5327


Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 67    Accepted Submission(s): 52


Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval  [a,b] (ab) . Please be fast to get the gold medal!
 

Input
The first line of the input is a single integer  T (T1000) , indicating the number of testcases. 

For each test case, there are two numbers  a  and  b , as described in the statement. It is guaranteed that  1ab100000 .
 

Output
For each testcase, print one line indicating the answer. 
 

Sample Input
  
  
2 1 10 1 1000
 

Sample Output
  
  
10 738
 

Source
 


AC code:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<map>
#include<cmath>
#define LL long long
#define MAXN 1000010
using namespace std;
const LL INF=0x3f3f3f3f;
int f[MAXN],fg[11];
int ans;
void init()
{
	memset(f,0,sizeof(f));
	int i,j;
	for(i=1;i<=10;i++)
	{
		f[i]=i;
	}
	for(i=11;i<=100001;i++)
	{
		int x=i;
		memset(fg,0,sizeof(fg));
		while(x)
		{
			int s=x%10;
			if(fg[s])
				break;
			fg[s]=1;
			x/=10;
		}
		if(x==0)
		{
			f[i]++;
		}
		f[i]+=f[i-1];
	}
}
int main()
{
	int t,a,b;
	init();
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d%d",&a,&b);
			ans=f[b]-f[a-1];
			printf("%d\n",ans);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值