HDU5327 Olympiad

Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1496    Accepted Submission(s): 931


Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (ab) . Please be fast to get the gold medal!
 

Input
The first line of the input is a single integer T (T1000) , indicating the number of testcases.

For each test case, there are two numbers a and b , as described in the statement. It is guaranteed that 1ab100000 .
 

Output
For each testcase, print one line indicating the answer.
 

Sample Input
  
  
2 1 10 1 1000
 

Sample Output
  
  
10 738
 

Author
XJZX
 

Source

2015 Multi-University Training Contest 4 

求给出的区间内有多少个YY数 (YY数就是各个位置的数都不同如12345)

一千组数据每组10万 再判断接近10亿 有时会超时看人品

事先需要打表


http://acm.split.hdu.edu.cn/showproblem.php?pid=5327


#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int aa[100010];
int main()
{
    int t,n,m,i,j,k;
    char str[10];
    aa[0]=0;
    int sum=0;
    for(i=1; i<=100000; i++)
    {
        itoa(i,str,10);
        int flag=1;
        for(j=0; str[j]!='\0'; j++)
        {
            for(k=j+1; str[k]!='\0'; k++)
                if(str[j]==str[k])
                {

                    flag=0;
                    break;
                }
            if(!flag) break;
        }
        if(flag)
        {
            sum++;aa[i]=sum;
        }
        else aa[i]=sum;
    }

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        printf("%d\n",aa[m]-aa[n-1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值