hdu 5363 Key Set

hdu 5363 的传送门

Problem Description

soda has a set S with n integers {1,2,…,n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:

The first line contains an integer n (1≤n≤109), the number of integers in the set.

Output

For each test case, output the number of key sets modulo 1000000007.

Sample Input

4
1
2
3
4

Sample Output

0
1
3
7

题目大意:给你一个数m,然后有m个数,这个数有多少个和是偶数的集合,e:给你3,集合有{1},{1,2},{1,3},
{1,2,3},{2},{2,3},{3}

然而和是偶数的只有{1,2},{1,3},{2,3};

解题思路:推出公式; ans=2 ^ (m-1) - 1;

下面上代码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int mod = 1000000007;
typedef long long LL;
LL quick(int m)
{
    m-=1;
    LL ans=1;
    LL tmp=2;
    while(m)
    {
        if(m&1)
        {
            ans=ans*tmp%mod;
            m--;
        }
        tmp=(tmp*tmp)%mod;
        m>>=1;
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int m;
        scanf("%d",&m);
        printf("%lld\n",quick(m)-1);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值