Intersecting Lines(直线相交判断,求相交交点)

73 篇文章 0 订阅
35 篇文章 0 订阅


Link:http://poj.org/problem?id=1269


Intersecting Lines
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12491 Accepted: 5576

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

Source



AC code:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<queue>
#include<map>
#define EPS 1e-8
using namespace std;
struct Point{
    double x;
    double y;
}p;
struct v{
    Point s;
    Point e;
}seg[22222];
v seg1,seg2;
/* 语法:result=mindistance(Point p1,Point p2,Point q);
	参数:p1~p4:直线上不相同的两点
	*p:通过指针返回结果
	返回值:1:两直线相交;2:两直线平行
	注意:如需要判断两线段交点,检验k和对应k1(注释中)的值是否在0~1之间,用在0~1之间的那个求交点
源程序:
typedef struct {
   double x,y;
} Point;*/
int linecorss(Point p1,Point p2,Point p3,Point p4,Point *p)
{
   double k;
   //同一直线
  if ((p4.x-p3.x)*(p1.y-p3.y)-(p4.y-p3.y)*(p1.x-p3.x)==0&&
        (p2.x-p1.x)*(p1.y-p3.y)-(p2.y-p1.y)*(p1.x-p3.x)==0) return 2;
   //平行,不同一直线
  if ((p4.y-p3.y)*(p2.x-p1.x)-(p4.x-p3.x)*(p2.y-p1.y)==0) return 0;
 
    k=((p4.x-p3.x)*(p1.y-p3.y)-(p4.y-p3.y)*(p1.x-p3.x))/((p4.y-p3.y)*(p2.x-p1.x)-(p4.x-p3.x)*(p2.y-p1.y));
//k1=((p2.x-p1.x)*(p1.y-p3.y)-(p2.y-p1.y)*(p1.x-p3.x))/((p4.y-p3.y)*(p2.x-p1.x)-(p4.x-p3.x)*(p2.y-p1.y));
   (*p).x=p1.x+k*(p2.x-p1.x);
   (*p).y=p1.y+k*(p2.y-p1.y);
   return 1;//有交点
}
int main()
{
   //freopen("D:\in.txt","r",stdin);
   int n,i,j,k,fg,t,cnt,ans;
	scanf("%d",&n);
	cnt=0;
	printf("INTERSECTING LINES OUTPUT\n");
   for(i=1;i<=n;i++)
   {
       scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&seg1.s.x,&seg1.s.y,&seg1.e.x,&seg1.e.y,&seg2.s.x,&seg2.s.y,&seg2.e.x,&seg2.e.y);
       int fg=linecorss(seg1.s,seg1.e,seg2.s,seg2.e,&p);
       if(fg==0) //平行,不同一直线
       		printf("NONE\n");
       else if(fg==1)//有交点
       {
       		printf("POINT %.2lf %.2lf\n",p.x,p.y);
	   }
	   else if(fg==2) //同一直线
	   {
	   		printf("LINE\n");
	   }
   }
   printf("END OF OUTPUT\n");
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值