Link:http://acm.hdu.edu.cn/showproblem.php?pid=5455
Fang Fang
Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)Total Submission(s): 193 Accepted Submission(s): 96
Problem Description
Fang Fang says she wants to be remembered.
I promise her. We define the sequence F of strings.
F0 = ‘‘f",
F1 = ‘‘ff",
F2 = ‘‘cff",
Fn = Fn−1 + ‘‘f", for n > 2
Write down a serenade as a lowercase string S in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in F , or nothing could be done but put her away in cold wilderness.
I promise her. We define the sequence F of strings.
F0 = ‘‘f",
F1 = ‘‘ff",
F2 = ‘‘cff",
Fn = Fn−1 + ‘‘f", for n > 2
Write down a serenade as a lowercase string S in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in F , or nothing could be done but put her away in cold wilderness.
Input
An positive integer
T
, indicating there are
T
test cases.
Following are T lines, each line contains an string S as introduced above.
The total length of strings for all test cases would not be larger than 106 .
Following are T lines, each line contains an string S as introduced above.
The total length of strings for all test cases would not be larger than 106 .
Output
The output contains exactly
T
lines.
For each test case, if one can not spell the serenade by using the strings in F , output −1 . Otherwise, output the minimum number of strings in F to split S according to aforementioned rules. Repetitive strings should be counted repeatedly.
For each test case, if one can not spell the serenade by using the strings in F , output −1 . Otherwise, output the minimum number of strings in F to split S according to aforementioned rules. Repetitive strings should be counted repeatedly.
Sample Input
8 ffcfffcffcff cffcfff cffcff cffcf ffffcffcfff cffcfffcffffcfffff cff cffc
Sample Output
Case #1: 3 Case #2: 2 Case #3: 2 Case #4: -1 Case #5: 2 Case #6: 4 Case #7: 1 Case #8: -1HintShift the string in the first test case, we will get the string "cffffcfffcff" and it can be split into "cffff", "cfff" and "cff".
Source
AC code:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<queue>
#include<vector>
#define LL long long
#define MAXN 100010
using namespace std;
string s1;
int len,k,fg,cnt,ans,fg2;
int main(){
//freopen("D:\\in.txt","r",stdin);
int T,cas,i;
scanf("%d",&T);
getchar();
for(cas=1;cas<=T;cas++)
{
char s2[MAXN];
getline(cin,s1);
//cin>>s1;
len=s1.length();
fg=0;
for(i=0;i<len;i++)
{
if(s1[i]=='c')
{
fg=1;
k=i;
break;
}
}
if(fg)
{
cnt=0;
for(i=k;i<len;i++)
{
s2[cnt++]=s1[i];
}
for(i=0;i<k;i++)
{
s2[cnt++]=s1[i];
}
}
else
{
ans=(len+1)/2;
printf("Case #%d: %d\n",cas,ans);
continue;
}
ans=1;
fg2=1;
int shuf=0;
for(i=1;i<len;i++)
{
if(s2[i]=='f')
{
shuf++;
}
else
{
if(s2[i]=='c')
{
if(shuf<2)
{
printf("Case #%d: -1\n",cas);
break;
}
else
{
ans++;
shuf=0;
}
}
else
{
printf("Case #%d: -1\n",cas);
break;
}
}
}
if(i==len&&shuf<2)
{
printf("Case #%d: -1\n",cas);
continue;
}
if(i==len)
{
printf("Case #%d: %d\n",cas,ans);
}
}
return 0;
}