POJ1650 Integer Approximation(“追赶法”搜索)

181 篇文章 0 订阅
112 篇文章 0 订阅


Link:http://poj.org/problem?id=1650


Integer Approximation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5767 Accepted: 1942

Description

The FORTH programming language does not support floating-point arithmetic at all. Its author, Chuck Moore, maintains that floating-point calculations are too slow and most of the time can be emulated by integers with proper scaling. For example, to calculate the area of the circle with the radius R he suggests to use formula like R * R * 355 / 113, which is in fact surprisingly accurate. The value of 355 / 113 ≈ 3.141593 is approximating the value of PI with the absolute error of only about 2*10 -7. You are to find the best integer approximation of a given floating-point number A within a given integer limit L. That is, to find such two integers N and D (1 <= N, D <= L) that the value of absolute error |A - N / D| is minimal.

Input

The first line of input contains a floating-point number A (0.1 <= A < 10) with the precision of up to 15 decimal digits. The second line contains the integer limit L. (1 <= L <= 100000).

Output

Output file must contain two integers, N and D, separated by space.

Sample Input

3.14159265358979
10000

Sample Output

355 113

Source

Northeastern Europe 2001, Far-Eastern Subregion


AC code:

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#define LL long long
#define INF 0xfffffff

using namespace std;

int main()
{
//	freopen("in.txt","r",stdin);
	int L,N,D,ansN,ansD;
	double A,p,minp;
	while(scanf("%lf%d",&A,&L)!=EOF)
	{
		N=1;
		D=1;
		ansN=N;
		ansD=D;
		minp=INF;
		while(N<=L&&D<=L)
		{
			p=A-1.0*N/D;
			if(fabs(p)<minp)
			{
				ansN=N;
				ansD=D;
				minp=fabs(p);
			}
			if(p<=0)
			{
				D++;
			}
			else
			{
				N++;
			}
		}
		printf("%d %d\n",ansN,ansD);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值