Pie(二分法+double输入用%lf,输出用%f!!!)

73 篇文章 0 订阅
46 篇文章 0 订阅


Link:http://poj.org/problem?id=3122


Pie
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19352 Accepted: 6319 Special Judge

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source



AC code:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#define LL long long
#define INF 0xfffffff
#define PI acos(-1)
#define EPS 1e-6
using namespace std;

double a[10010];
int n,f,r;

int group(double mid)
{
	int sum=0,i;
	for(i=0;i<n;i++)
	{
		sum+=(int)(a[i]/mid);
	}
	return sum;
}

double Bsearch(double low,double high)
{
	double mid;
	while(high-low>EPS)
	{
		mid=(low+high)/2;
		if(group(mid) >= f)
		{
			low=mid;
		}
		else
		{
			high=mid; 
		}
	}
	return mid;
}

int main()
{
//	freopen("in.txt","r",stdin);
	int i,t;
	double low,high,ans,sum; 
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&f);
		f++;
		high=0;
		sum=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&r);
			a[i]=PI*r*r;
			if(high<a[i])
				high=a[i];
		}
		low=0;
		ans=Bsearch(low,high);
		printf("%.4f\n",ans);//大坑:注意 double输入用%lf,输出用%f,输出不能用%lf,因为这个poj一直wa!!!
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值