poj2976 二分最大平均值

27 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=2976

Dropping tests
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7697 Accepted: 2686

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ aibi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source

 

 

思路:对于平均数X,C(m,k,n):是否存在选取n-k个数的平均值>=m .如果存在,在右边搜索,否则在左边搜索。

如果满足C,则有sigma(xi-m*yi)>=0.因此按照xi-m*yi从大到小排序,如果和>=0,则存在。

注意输出,%.0f是按照输出0位小数但是第一位小数四舍五入,而%d不会四舍五入。

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
#define MAXN  1005
#define eps 1e-7
struct node
{
 int x,y;
}a[MAXN];
double b[MAXN];

int C(double x,int k,int n)
{
 int i;
 for(i=0;i<n;i++)
 {
  b[i]=a[i].x-x*a[i].y;
 }
 sort(b,b+n);
 double sum=0;
 for(i=0;i<n-k;i++)
 {
  sum+=b[n-1-i];
 }
 if(sum>=0)
  return 1;
 return 0;
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
 int n,k;
 while(cin>>n>>k)
 {
  if(!n&&!k)
   break;
  int i;
  double l=0,r=1.0;
  for(i=0;i<n;i++)
  {
   cin>>a[i].x;
   r+=a[i].x;
  }
  for(i=0;i<n;i++)
   cin>>a[i].y;
  while(r-l>eps)
  {
   double mid=(l+r)/2;
   if(C(mid,k,n))
    l=mid;
   else
    r=mid;
  }
  printf("%.0f\n",l*100);
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值