Problem Link:http://acm.hdu.edu.cn/showproblem.php?pid=4730
We Love MOE Girls
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3650 Accepted Submission(s): 2053
Problem Description
Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.
In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".
There are two situations:
If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.
Given an original sentence, what will it sound like aften spoken by Nanako?
Input
The first line has a number T (T <= 1000) , indicating the number of test cases.
For each test case, the only line contains a string s, which is the original sentence.
The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.
Output
For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output which Nanako will say.
Sample Input
2 ohayougozaimasu daijyoubudesu
Sample Output
Case #1: ohayougozaimasunanodesu Case #2: daijyoubunanodesu
Source
2013 ACM/ICPC Asia Regional Chengdu Online
AC code:
#include<bits/stdc++.h>
using namespace std;
int main()
{
// freopen("D:\\in.txt","r",stdin);
int t,i,len;
string str;
cin>>t;
for(i=1;i<=t;i++)
{
cin>>str;
len = str.length();
if(len>=4 && str[len-1]=='u'&&str[len-2]=='s'&&str[len-3]=='e'&&str[len-4]=='d')
{
str[len-1]='o';
str[len-2]='n';
str[len-3]='a';
str[len-4]='n';
str+="desu";
}
else
str+="nanodesu";
cout<<"Case #"<<i<<": "<<str<<endl;
}
return 0;
}