UVa10003 - Cutting Sticks(区间DP)

102 篇文章 0 订阅
6 篇文章 0 订阅

Problem Link:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=944

 

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.

It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.

Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick. Input The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n (n < 50) of cuts to be made. The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order. An input case with l = 0 will represent the end of the input. Output You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

 

Sample Input

100

3

25 50 75

10

4

4 5 7 8

0

Sample Output

The minimum cutting is 200.

The minimum cutting is 22.

 

题意:给出一个长度为L木棍,以及n个切割点 。要求切割成n+1段,每切一次花费都是原始的木棍长度 ,求最小花费。

分析实际上我们可以看做是n+1个物品,转化成区间dp的石子合并问题。
设计状态:dp[i][j]表示切割编号为(i~j)的木棍的花费。

dp[i][j]=min{dp[i][k]+dp[k+1][j]+sum[j]-sum[i-1]}

•sum[i]是前i段木棍的前缀和,实际上就是分割点 
唯一需要注意就是现在有n+1个物品了(n+1堆石子)。

AC code:

#include<bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
const int maxn=55;
int l,n,c[maxn],dp[maxn][maxn],s[maxn][maxn],sum[maxn];

int main()
{
	int i,j,k,len;
	while(cin>>l)
	{
		if(l==0) break;
		cin>>n;
		sum[0]=0;
		memset(dp,INF,sizeof(dp));
		for(i=1;i<=n;i++)
		{
			cin>>c[i];
			sum[i]=c[i];
			dp[i][i]=0;
			s[i][i]=i;
		}
		sum[n+1]=l;
		dp[n+1][n+1]=0;
		s[n+1][n+1]=n+1;
		for(len=2;len<=n+1;len++)
		{
			for(i=1;i<=n+1;i++)
			{
				j=i+len-1;
				if(j>n+1) break;
				for(k=s[i][j-1];k<=s[i+1][j];k++)
				{
					//dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+sum[j]-sum[i-1]);
					if(dp[i][j]>dp[i][k]+dp[k+1][j]+sum[j]-sum[i-1])
					{
						dp[i][j]=dp[i][k]+dp[k+1][j]+sum[j]-sum[i-1];
						s[i][j]=k;
					}
				}
			}
		}
		cout<<"The minimum cutting is "<<dp[1][n+1]<<"."<<endl;
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值