A - 连连看 HDU - 1175

Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。

Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!

Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。

Sample Input

3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0

Sample Output

YES
NO
NO
NO
NO
YES

#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

const int N = 1010;

int dx[] = {0, -1, 0, 1}, dy[] = {-1, 0, 1, 0};
int n, m;
int g[N][N];
bool st[N][N];
int X1, Y1, X2, Y2;

struct node {
	int x, y;
	int step;
};

void bfs(int a, int b) {
	queue<node> q;
	node One, next;
	One.x = a, One.y = b, One.step = -1;
	q.push(One);
	st[a][b] = true;

	while (q.size()) {
		auto t = q.front();
		q.pop();

		if (t.x == X2 && t.y == Y2 && t.step <= 2) {
			puts("YES");
			return;
		}
		for (int i = 0; i < 4; i ++ ) {
			next.x = t.x + dx[i], next.y = t.y + dy[i];
			next.step = t.step + 1;

			while (next.x >= 1 && next.x <= n && next.y >= 1 && next.y <= m && !g[next.x][next.y]) {//是0才能走
				if (!st[next.x][next.y]) {
					st[next.x][next.y] = true;
					q.push(next);
				}

				next.x = next.x + dx[i], next.y = next.y + dy[i];//在step方向不改的情况下,一直走
			}
		}
	}

	puts("NO");  // 存在搜索完找不到答案的情况
	return;
}

int main() {
	while (cin >> n >> m) {
		if (n == 0 && m == 0)
			break;

		for (int i = 1; i <= n; i ++ )
			for (int j = 1; j <= m; j ++ )
				cin >> g[i][j];

		int q;
		cin >> q;

		while (q -- ) {
			memset(st, false, sizeof st);
			cin >> X1 >> Y1 >> X2 >> Y2;

			if (g[X1][Y1] != g[X2][Y2]) {
				puts("NO");
				continue;
			} else if (!g[X1][Y1] && !g[X2][Y2]) {
				puts("NO");
				continue;
			} else {
				int t = g[X1][Y1]; // 保存地图的原貌
				g[X1][Y1] = g[X2][Y2] = 0;
				bfs(X1, Y1);
				g[X1][Y1] = g[X2][Y2] = t;//恢复,为了下一次搜索
			}
		}
	}

	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值