程序设计思维与实践 Week15 作业

魔咒词典

Problem Description
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

Sample Input
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output
light the wand
accio
what?
what?

Author
ZJU

思路:采用字符串HASH方法,将咒语部分和功能部分转化为数字分别存储在两个map<unsigned long long,int>的变量中,其中int的值是一个序列,此序列对应字符串数组ss中相应的字符串,之后对于查询的每一个字符串,判断其是咒语还是功能,再将其转化为数字在相应的map中查找其序列,若输入为咒语,则输出序列对应功能,反之则输出对应咒语。
其中转化方程为:
在这里插入图片描述
seek=7;

#include <iostream>
#include <map>
#include <string>
#include <cmath>
using namespace std;
string z[100000+10];
//string g[100000+10];
string s1,ss;
const int seek=7;
map<unsigned long long,int> zy;
map<unsigned long long,int> gn;
unsigned long long temp,h;
int i,n,l,r;
unsigned long long hash_count(string s,int ll,int rr){
	temp=seek;
	unsigned long long hh=0;
	for(int k=ll;k<rr;k++){
		  	if(s[k]!=' '){
		  		hh+=s[k]*temp;
		  		temp*=temp;
			  }
		}
		return hh;
}
int main(){
	i=1;
	while(1){
		getline(cin,s1);
		if(s1=="@END@") break;
		r=0;
		while(s1[r]!=']'){
			r++;
		}
		h=hash_count(s1,1,r);
		zy[h]=i;
		//z[i].insert(0,s1,1,r-1);
		//cout<<z[i]<<endl;
		h=hash_count(s1,r+2,s1.size());
		gn[h]=i;
		//g[i].insert(0,s1,r+2,s1.size());
		//cout<<g[i]<<endl;
		z[i]=s1;
		i++;
	}
	cin>>n;
	getchar();
	for(int k=0;k<n;k++){
		getline(cin,ss);
		if(ss[0]=='['){
			h=hash_count(ss,1,ss.size()-1);
			if(zy[h]>0){
				int i=0;
				while(z[zy[h]][i]!=']') i++;
				i+=2;
				for(i;i<z[zy[h]].size();i++) cout<<z[zy[h]][i];
				cout<<endl;
			}
			else cout<<"what?"<<endl;
		}
		else{
			h=hash_count(ss,0,ss.size());
			if(gn[h]>0){
				int i=1;
				while(z[gn[h]][i]!=']'){
					cout<<z[gn[h]][i];
					i++;
				}
				cout<<endl;
			}
			else cout<<"what?"<<endl;
		}
	}
	
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值