E - Squares

E - Squares


A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0
Sample Output
1
6
1


题意:给出一些点,判断这些点能形成几个不同的正方形。

题解:首先是判断能否形成正方形。如果四个点四个点判断一定超时。先根据两个点算出另外两个点的坐标,再判断那两个点是否存在。但是在判断的时候不能直接查找,要用二分法查找,不然依旧会超时。网上找的判断正方形的公式:

已知: (x1,y1)  (x2,y2)

则:   x3=x1+(y1-y2)   y3= y1-(x1-x2)

x4=x2+(y1-y2)   y4= y2-(x1-x2)

x3=x1-(y1-y2)   y3= y1+(x1-x2)

x4=x2-(y1-y2)   y4= y2+(x1-x2)



#include <cmath>
#include <queue>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

typedef struct point
{
    int x;
    int y;
}PO;

bool cmp(PO x,PO y)
{
    if(x.x == y.x) return x.y < y.y;
    else return x.x < y.x;
}

void trans(PO i,PO j,PO &C,PO &D,int f)
{
    int tx = i.x - j.x;
    int ty = i.y - j.y;
    C.x = i.x + f * ty;
    C.y = i.y - f * tx;
    D.x = j.x + f * ty;
    D.y = j.y - f * tx;
}

bool find(PO P[],int n,PO C)
{
    int l,r;
    l = 0,r = n - 1;
    while(l <= r)
    {
        int mid = (l + r) / 2;
        if(P[mid].x == C.x)
        {
            if(P[mid].y == C.y) return true;
            if(P[mid].y > C.y)
            {
                r = mid - 1;
            }
            if(P[mid].y < C.y)
            {
                l = mid + 1;
            }
        }
        if(P[mid].x < C.x)
        {
            l = mid + 1;
        }
        if(P[mid].x > C.x)
        {
            r = mid - 1;
        }
    }
    return false;
}

int main()
{
    int n;
    while(scanf("%d",&n) && n)
    {
        PO P[1000];
        int ans = 0;
        for(int i = 0;i < n;i++)
        {
            scanf("%d%d",&P[i].x,&P[i].y);
        }
        sort(P,P + n,cmp);
        for(int i = 0;i < n;i++)
        {
            for(int j = i + 1;j < n;j++)
            {
                PO C,D;
                trans(P[i],P[j],C,D,1);
                if(find(P,n,C) && find(P,n,D)) ans++;
                trans(P[i],P[j],C,D,-1);
                if(find(P,n,C) && find(P,n,D)) ans++;
            }
        }
        printf("%d\n",ans / 4);
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值