POJ 2002 Squares 哈希

6 篇文章 0 订阅

Squares
Time Limit: 3500MS
Memory Limit: 65536K
Total Submissions: 16836
Accepted: 6403

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source


给出n组坐标,看看能组成几个正方形。。。。。


这是一篇WA的代码:我也没能找出哪错了,先记下来,多想几组比较恶心的测试数据再来调试。。。。


#include <stdio.h>
#include <string.h>

struct node
{
    int y;
    node *next;
}head[40010];

struct Zb
{
    int x;
    int y;
}ls[1010];

bool hs_sch(int x,int y)
{
    if(x >= 20000 || x <= -20000 || y >= 20000 || y <= -20000)
        return false;
    int sx;
    if(x < 0)
        sx = -x + 20000;
    else
        sx = x;
    node *p = head[sx].next;
    while(p)
    {
        if(p->y == y)
            return true;
        p = p->next;
    }
    return false;
}

int main()
{
    int n,cnt;
    while(scanf("%d",&n),n)
    {
        cnt = 0;
        int sx;
        memset(head,0,sizeof(head));
        for(int i = 0;i < n;i++)
        {
            scanf("%d%d",&ls[i].x,&ls[i].y);
            if(ls[i].x < 0)
                sx = -ls[i].x + 20000;
            else
                sx = ls[i].x;
            node *p = &(head[sx]);
            while(p->next)
            {
                p = p->next;
            }
            node *r = new node;
            r->y = ls[i].y;
            r->next = NULL;
            p->next = r;
        }
        for(int i = 0;i < n;i++)
        {
            for(int j = i + 1;j < n;j++)
            {
                int x1 = ls[i].x + ls[i].y - ls[j].y;
                int y1 = ls[i].y - (ls[i].x - ls[j].x);
                int x2 = ls[j].x + ls[i].y - ls[j].y;
                int y2 = ls[j].y - (ls[i].x - ls[j].x);
                if(hs_sch(x1,y1) && hs_sch(x2,y2))
                {
                    cnt++;
                }
            }
        }
        printf("%d\n",cnt >> 1);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值