H - Cow Contest POJ - 3660

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题意:题目大意:有N头牛,评以N个等级,各不相同,先给出部分牛的等级的高低关系,问最多能确定多少头牛的等级。

题解:一头牛当且仅当他的关系和其他n - 1头牛的关系确定时,他的次序就可以确定。于是我建了一个有向图,如果a 比 b 强则a到b的距离为1,否则为无穷,对每一个点都跑一次SPFA最短路,然后遍历所有点,看与这个点确定关系的有哪些点。最后在找出确定关系的点数有n - 1个的点的数量。

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 5010;
int head[maxn],dis[maxn],inq[maxn],cont[maxn],n,m,tot;
//cont[i]记录与i点确定关系的点有多少个

struct node
{
    int v;
    int next;
    int w;
}edg[maxn];

void addnode(int u,int v,int w)
{
    edg[tot].v = v;
    edg[tot].w = w;
    edg[tot].next = head[u];
    head[u] = tot++;
}

void SPFA(int s)
{
    queue<int>Q;
    Q.push(s);
    inq[s] = 1;
    dis[s] = 0;

    while(!Q.empty())
    {
        int u = Q.front();
        Q.pop();
        inq[u] = 0;
        for(int i = head[u];i != -1;i = edg[i].next)
        {
            int v = edg[i].v,w = edg[i].w;
            if(dis[v] > dis[u] + w)
            {
                dis[v] = dis[u] + w;
                if(!inq[v])
                {
                    Q.push(v);
                    inq[v] = 1;
                }
            }
        }
    }
}

int main()
{
    scanf("%d %d",&n,&m);

    tot = 0;
    memset(cont,0,sizeof(cont));
    memset(head,-1,sizeof(head));

    for(int i = 1;i <= m;i++)
    {
        int u,v;
        scanf("%d %d",&u,&v);
        addnode(u,v,1);
    }

    for(int i = 1;i <= n;i++)
    {
        memset(dis,inf,sizeof(dis));
        memset(inq,0,sizeof(inq));
        SPFA(i);

        for(int j = 1;j <= n;j++)//遍历所有点找到与i点有关系的点
        {
            if(i == j) continue;
            if(dis[j] != inf)//如果i,j确定了关系,则i,j的关系数都要+1
            {
                cont[j]++;
                cont[i]++;
            }
        }
    }

    int ans = 0;
    for(int i = 1;i <= n;i++)//遍历所有点找可以确定排序的点的个数
    {
        if(cont[i] == n - 1)
            ans++;
    }

    printf("%d\n",ans);

    return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值