H - Cow Contest POJ - 3660(Floyd)

H - Cow Contest POJ - 3660

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题意:有N头牛,评以N个等级,各不相同,先给出部分牛的等级的高低关系,问最多能确定多少头牛的等级。

思路:现将已知两头牛的关系按照单向图存入a,通过Floyd把传递关系弄出来。现在当一个点的出度+入度和等于n-1(即和他和所有的点都直接或间接的确定了关系),那么他的关系就确定了。

代码:

#include <iostream>
#include <stdlib.h>
#include <queue>
#include <cstring>
#define inf 0x3f3f3f

using namespace std;

int a[102][102];
int n,m;

void floyd() 
{
    int i,j,k;

    for ( i=1; i<=n; i++ ) {
        for ( j=1; j<=n; j++ ) {
            for ( k=1; k<=n; k++ ) {
                if ( a[j][i]!=0 && a[i][k]!=0 ) { // 做出传递关系
                    a[j][k] = 1;
                }
            }
        }
    }
}

int main()
{
    int i,j;
    cin >> n >> m;
    memset(a,0,sizeof(a));
    for ( i=0; i<m; i++ ) {
        int x,y;
        cin >> x >> y;
        a[x][y] = 1;
    }
    floyd();

    int ans = 0;
    for ( i=1; i<=n; i++ ) {
        int isp = 1;
        for ( j=1; j<=n; j++ ) {
            if ( i!=j && a[j][i]==0 && a[i][j]==0 ) { // 当出度=0入度=0,
                isp = 0; //       还不是自己和自己,那么不是确定关系的点
            }
        }
        if ( isp==1 ) {
            ans ++;
        }
    }
    cout << ans << endl;

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值