HDU 1520 Anniversary party

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0

Sample Output

5

AC的第一道树形dp,一开始由于使用了四次memset函数导致程序运行内存超限,改为一次后AC了,(若不用memset,初始化可能会浪费时间!)但空间复杂度还是很悬啊。。。此后应该谨慎使用memset啊。。。

状态方程:(dp[x][0]表示x不参加的最优解,dp[x][1]表示x参加的最优解,y为其下属)

               dp[x][0]+=max(dp[y][0],dp[y][1]);

               dp[x][1]+=dp[y][0];(x去了下属就不可以去);

p.s:个人认为员工与其下属关系的存储很巧妙!(也可能我太菜。。。)



#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int dp[6001][2];
int yg[6005][6005];
int h[6001];
bool ss[6001]; 
void dfs(int x){
    int i,y;
    dp[x][0]=0;
    dp[x][1]=h[x];
    for(i=1;i<=yg[x][0]&&yg[x][i];++i){
        y=yg[x][i];
        dfs(y);
        dp[x][0]+=max(dp[y][0],dp[y][1]);
        dp[x][1]+=dp[y][0];
    }
}
int main(){
    int n,i,j,x,y;
    while(scanf("%d",&n)!=EOF){
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;++i){
            scanf("%d",&h[i]);
            yg[i][0]=0;
            ss[i]=0;
        }
        while(scanf("%d %d",&x,&y),x||y){
            yg[y][++yg[y][0]]=x;//yg[y][0]表示y的下属的个数
            ++ss[x];//ss[y]表示y是否有上级
        }
        i=0;
        while(ss[++i]);
        dfs(i);
        printf("%d\n",max(dp[i][1],dp[i][0]));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 6
    评论
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值